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INTRODUCTION 

This guide provides customers with clear steps to install, activate, and begin using the LSSA DPL Cad Template and 
Tool Palette in your CAD Application.  

These routines have been tested in the following software within the provided template: 

1. AutoCAD (2022, 2025) 
2. BricsCAD (V24, V25, V26 and Pro) 
3. CMS Intellicad 14.1 Premium Edition  
4. MicroSurvey CAD 2026 

INSTALLATION GUIDE 

1. System Requirements 

Access to the DPL shared folder/zip file with the required blocks, template and palette files (available upon 
request by emailing dpl@landservices.com.au) 

2. Downloading the Software 

1. Download the LSSA folder containing the blocks, lisp routines, fonts and the LSSA DPL Template file 

2. Unzip and save the contents in a dedicated directory (or your CAD Drafting Resource directory) 

3. Download the required Palette folder from the Palettes directory in the DPL shared folder and place it within 
the unzipped folder 

4. To add the tool palette to your CAD software, AutoCAD users can refer section 2.2.1 below, for BricsCAD follow 
the steps in 2.2.2 

 2.2.1 AutoCAD 

 1. Open AutoCAD -> Open the drawing template and save it as a .dwg file 

2. Type in ‘OPTIONS’ in the command line  

3. Go to the ‘Files’ tab 

4. Expand ‘Support File Search path’ 

5. Click on ‘Add’ 

6. Click ‘Browse’ 

CAD Tools 
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7. Select the directory where you saved the unzipped files 

 

8. Now expand ‘Tool Palettes File Locations’ 

9. Click ‘Add’ 

10. Click ‘Browse’ 

11. select the ‘Palettes’ directory where you saved the unzipped files 

 

12. Click ‘Apply’ and then ‘OK’ 

13. Drag and drop the ‘LSSA.lsp’ file into AutoCAD’s drawing window. Alternatively, navigate to ‘Load 
Application’ under the ‘Manage’ menu. Click on ‘Contents…’ under start up suite and ensure that it is empty. 
Then, load the ‘LSSA.lsp’ file. This loads the required routines to work with the palette icons while ensuring 
that there are no clashes with other lisp files. Another option is to type ‘APPLOAD’ into the command line to 
open the Load Application window. 
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14. Next, navigate to and click on the ‘Tool Palettes’ item in the ‘View’ menu or type “TOOLPALETTES” into 
the command line 

 

15. The Palettes should now appear on your screen. Right click on the empty area in the Tool Palette and click 
‘Customize Palettes…’ 

 

16. You should see the Palettes on the left side on the popup window that appears. In the case that these 
palettes aren’t present, right click on the left panel and click ‘Import…’ 

 

17. Select the .xtp files of each of the Palettes (these are present in the ‘Palettes’ folder in the directory 
where you saved the unzipped files)  
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18. Once all palettes are imported, it looks like this 

 

19. To group the LSSA tool palettes, import the LSSA.xpg file in the right panel 
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20. To view only the group, right click on the tool palettes header and select the ‘LSSA’ group 

 

21. Click ‘Close’. You should now see the Tool Palettes with the appropriate Tools 

       

 

2.2.2 BricsCAD 

 1. Open BricsCAD -> Open the drawing template and save it as a .dwg file 

2. Type in ‘OPTIONS’ in the command line  

3. Expand ‘Files’ 

4. Double click ‘Support File Search path’ – click on the 3 dots (…) 
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5. Click on the ‘Add Path’ icon -> three dots (…) 

 

6. Select the path to the folder of your unzipped directory 

7. Scroll to and expand the Tool Palettes menu (can be found under files further down) 

8. Click on ‘Tool Palettes path’ -> three dots (…) 

9. Click on the ‘Add Path’ icon -> three dots (…) 

10. Select the path to the ‘BricsCAD’ directory in the saved folder 

 

11. Click ‘OK’ and close the options window 

12. Drag the lisp file into the drawing panel. Alternatively, navigate to the ‘Load Application’ under the 
Manage menu or type ‘APPLOAD’ into the command line. If there are any lisp files already loaded, remove 
them by selecting the file entry and clicking the remove button on the top right.  Click on add and select the 



  

   
7 

lisp file from the directory containing the unzipped files. Ensure that the options ‘Loaded’ and ‘Autoload’ are 
selected. Close the load window. 

 

13. Type in the command ‘TOOLPALETTES’ in the command line. This makes the Tool Palette icon visible in 
the right icon panel. Alternatively, select the ‘Tool Palettes’ option under the ‘View’ menu 

    

14. Click the three dots (…) in the Tool Palette area and click ’Customize palettes…’ 
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15. Locate the required Palettes on the right-side panel and drag them over to the Palette Group on the left 

 

16. Click ‘Close’. You should now see the Tool Palettes with the appropriate Tools

 

2.2.3 MicroSurvey 

1. Copy the unzipped folder to the location: C:\ProgramData\MicroSurvey\MSCAD\2026\mscad\. This is for 
ease of use as MicroSurvey already references this folder for other similar resources 

2. Open the Routines folder within the unzipped directory, find the LSSA.lsp file, and copy it to the mscad 
folder 

3. Navigate to ‘C:\Program Files\MicroSurvey\MSCAD2026’. Locate the ‘icad.lsp’ file. Copy this file and paste 
it on your desktop (since the file cannot be edited without admin access from this location). Right click and 
‘Edit with Notepad (/++)’. Add the following line to the file: (load "LSSA"). Save and exit 

 

4. Copy this edited icad.lsp and paste it back to the original location: ‘C:\Program 
Files\MicroSurvey\MSCAD2026’. Replace the file when prompted 

5. Open Microsurvey. In the Project Manager window, check the ‘Use Template’ checkbox. Click the ‘Set 
Template’ button. Navigate to and select the template file within the ‘Template’ folder in the location where 
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you pasted the unzipped folder (C:\ProgramData\MicroSurvey\MSCAD\2026\mscad\). This will now ensure 
that the template is used everytime you create a new drawing 

 

6. When the drawing config popup appears set the distances to ‘Metric’ and the Directions to ‘Azimuth DMS’. 
Set these defaults as permanent so that you don’t get the popup for every drawing and click ‘OK’ 

7. Type in ‘OPTIONS’ in the command line. Alternatively, click on the Microsurvey menu and click on ‘Options’ 

 

8. Navigate to the ‘Paths/Files’ panel 
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9. Expand ‘Tool Palettes File Location’. Click ‘Add’ and browse for the folder containing the palette files in the 
unzipped directory. Click ‘OK’ 

 

8. Click ‘OK’ 

9. Type the command ‘APPLOAD’ into the command line. Alternatively navigate to the Tools menu in the 
toolbar and click on ‘Load Application’. This opens a window to load the required LISP file 

10. Click ‘Add File…’ 

11. Set ‘Files of type’ as ‘LISP Application (*.lsp)’ and navigate to and select the ‘LSSA.lsp’ file provided in the 
Routines folder in the unzipped directory. Click ‘Open’ 
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12. Click ‘OK’. Then click ‘Load’. This loads all the routines required for the tools to work 

 

13. Type the commands ‘TOOLPALETTES’ into the command line. Alternatively, click the ‘Tool Palettes’ option 
under the ‘View’ menu in the toolbar. You should be able to see the added tool palettes appear along with 
the default ones. In the event the palettes do not appear, follow steps 5-10 from the ‘UPDATING AN 
EXISITING DPL CAD TEMPLATE AND TOOL PALETTES’ section below 

14. In the case you want to group and view only the required tool palettes type the command ‘CUSTOMIZE’ 
into the command line. The palette customization window appears. Right click on the empty space in the 
right panel click new group. Name the group ‘LSSA’ and drag in the relevant palettes 

 

15. Click ‘Close’ 

16. Right click the palette header and select the LSSA group 

 

17. Now only the LSSA provided palettes will be visible. To use the tools click on the palette icons for the 
required action 
 

2.2.4 InteliiCAD 
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1. Copy the Intellicad folder from the unzipped files and paste them into the location: 

C:\Users\<username>\AppData\Roaming\CMS\CMS IntelliCAD 14.1 Premium Edition x64 

 

2. Open IntelliCAD -> Open the drawing template and save it as a new .dwg fil 

3. Type in ‘OPTIONS’ in the command line or navigate to the main menu and click on ‘Options’ 

 

4. Click ‘Files’ 

5. Navigate to and expand ‘Tool Palette Locations’. Click on it and select ‘Add’ 

 

6. Click ‘Browse’ and navigate to ‘Palette’ folder in the directory where you placed the IntelliCAD folder in 
step 1 
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7. In the ‘Files’ panel navigate to and expand ‘LISP’ and add the Routines folder from the directory where you 
stored the unzipped folder 

 

8. Click ‘OK’ 

9. To load the lisp file, click on the ‘Load Application’ option under the ‘Tools’ menu in the tool bar. Click ‘Add 
File…’ and browse to the LSSA.lsp file in the Routines folder. Click ‘Load’ and then ‘OK’ 

 

10. To view the tool palettes type the command ‘TOOLPALETTES’ into the command line. Alternatively, click 
on the ‘Tool Palettes’ option under the View menu in the toolbar  

11. To add and use the LSSA palettes, right click on the empty space in the palettes and click on ‘Customize 
Palettes’. The customize tool palettes window appears with two panels 

12. Right click on the empty space in the left panel and click ‘Import’. Browse to and import all the relevant 
.xtp files which can be found within the ‘Palettes’ folder in the directory where you placed the unzipped files 

 

13. To create a palette group to view only LSSA palettes right click on the empty space in the right panel and 
click ‘New Group’ and name the created group ‘LSSA’. Drag the relevant palettes into this group from the left 
panel. Click ‘Close’ 
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14. To view the created palette group, right click on the palette header and select the LSSA group 

 

15. You should now see the new tool palettes 

 

 

BASIC USAGE GUIDE 

The tools can be used by clicking on the icon representing the required tool. Preferentially, if you know the command, 
typing it into the command line also works. 

UPDATING THE ROUTINES 

If the lisp routines need to be updated at any point, drag and drop the relevant lisp file into the drawing. Alternatively, 
use the ‘APPLOAD’ command or the ‘Load Application’ option under the ‘Manage’ menu as described in the steps 
above. 

UPDATING AN EXISITING DPL CAD TEMPLATE AND TOOL PALETTES 

If any changes have been made to the tool palette, it must be updated for those changes to become visible. This may 
include adding new tools, removing existing ones, or modifying the commands associated with certain tools. 

To update the tool palette in your CAD software, follow the steps below: 

1. Ensure that all CAD software is closed 
2. Extract and copy the contents of the new zip file 
3. Replace the contents of the directory where you saved the contents of the old, unzipped file with the new 

contents. This ensures that the new contents are available to your software without breaking any links. 
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4. Open and save the new template as .dwg 

 
5. Reopen your CAD software. Find the steps that correspond to your CAD software from below and follow 

them. 

AutoCAD 

1. Open the tool palette 
2. Right click on the empty space on the palette and select ‘Customize Palettes…’ 
3. Delete the palette(s) to be updated 

 
 

4. Right click on the empty space on the left panel and click ‘Import…’  
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5. Import the .xtp files for the palettes to be updated 

 
 

6. Click ‘Close’ 
7. The updated tools should now be visible on the palette. 

BricsCAD  

1. Open the tool palette 
2. Right click on the empty space on the palette and select ‘Customize Palettes…’ 
3. Remove the updated palette from the group. If multiple palettes have been updated remove all of them 

 

 
 

4. Delete it from the left panel as well. 
 

 
 

5. Right click on the empty space in the left panel  
6. Click ‘Import’ 
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7. Select the .xtp file for the palette that needs to be update 
 

 
 

8. Click ‘Open’. You will see the palette added back to the left pane 
9. Once imported, drag the palette from the left panel to the group on the right 
10. Click ‘Close’ 
11. The palette will now contain the updated commands. 

MicroSurvey  

1. Open the tool palette 
2. Right click on the empty space on the palette and select ‘Customize Palettes…’ 
3. Delete the updated palette from the group. If multiple palettes have been updated delete all of them. 

 

 
 

4. Delete it from the left panel as well. 
 

 
 

5. Right click on the empty space in the left panel  
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6. Click ‘Import’ 

 
7. Select the .xtp file for the palette that needs to be updated 

 

 
 

8. Click ‘Open’. You will see the palette added back to the left panel. 
9. Once imported, drag the palette from the left panel to the group on the right 

 
10. Click ‘Close’ 
11. The palette will now contain the updated commands. 

IntelliCAD 

1. Open the tool palette 
2. Right click on the empty space on the palette and select ‘Customize Palettes…’ 



  

   
19 

3. Delete the updated palette from the group. If multiple palettes have been updated delete all of them. 
 

 
 

4. Delete it from the left panel as well. 
 

 
 

5. Right click on the empty space in the left panel  
6. Click ‘Import’ 

 
7. Select the .xtp file for the palette that needs to be updated. 

 
 

8. Click ‘Open’. You will see the palette added back to the left panel. 
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9. Once imported, drag the palettes from the left panel to the group on the right. 

 
10. Click ‘Close’ 
11. The palette will now contain the updated commands. 

TROUBLESHOOTING 

AutoCAD 

If your tool palette is empty after restart:                                                                                    

  This occurs when AutoCAD retains the old palette group without the new palettes.                                             

  Solution 1: Recreate the palette group 

1. Create a new tool palette group 

2. Add the newly imported palettes to it 

  Solution 2: Import the provided group file 

1. Use the .xpg file provided to import the complete palette group 

BricsCAD 

Tool palette images may not appear in BricsCAD after installation. This can be fixed by following these steps: 

1. Locate the images in the saved directory. This should be present under Palette -> BricsCAD -> 

<Palette-name> -> Images directory.  

2. Copy the images and paste them into the location: 

C:\Users\<username>\AppData\Roaming\Bricsys\BricsCAD\V<version-

number>\en_US\Support\ToolPalettes\Palettes\Images 

3. The tool images should now be available in the Tool Palettes 

MicroSurvey 

If tools don't display properly in MicroSurvey, type ‘CUSTOMIZE’ into the command line to access the palette 

customization window. Alternatively, right click on the empty portion of the tool palette panel and click 

‘Customize Palettes’. 

1. Click ‘Reset’. This removes all the added templates and leaves the default ones. If you do not wish to 

remove all the palettes, right click on the palette you want to remove on the left panel and click 

‘Delete’. After this, follow either step 2 OR 3-4. 

2. Retry steps 2-8 from the installation steps. 



  

   
21 

3. In the customization window, right click on the empty space in the left panel and click ‘Import'. 

 
4. Browse and add the .xtp files of the relevant palettes. 

 
5. Recreate the LSSA group as per steps 14-16 in the installation steps. 

6. The tool palettes should reappear. 

IntelliCAD 

If the tool icons do not appear correctly in IntelliCAD, ensure that the IntelliCAD folder from the unzipped file 

is placed in C:\Users\<username>\AppData\Roaming\CMS\CMS IntelliCAD 14.1 Premium Edition x64. 

Ensure that this folder has the following structure: 

 

Ensure the Tool Palette Path in options is pointing to this ‘Palettes’ folder and all xtp files are imported from 

here too.  


